Author Topic: SEGA Master System Plugin Adapter Problem [Solution: Update firmware]  (Read 14514 times)

Offline Games Xtreme

  • Baby Retrode
  • *
  • Posts: 10
  • Karma: +2/-0
    • View Profile
    • Games Xtreme's Gaming & Modding
The Plugin-Adapter for the Retrode doesn't work at the actual firmware (0.18b) and with older firmwares ist gave my always "GenericROMinSegaSlot" .
When I connect my Retrode2+Adapter+Game to my PC it shows the retrode.cfg-file and the ROM (TmrSega2.sms).
If I try to copy the ROM or to start it in an emulator the config file and the ROM disappears.
Also the READ-LED changes from off to permanently on.
The "Retrode-USB-Drive" (in my case "F:/") remains at "My Computer" but it's empty and will be empty as long as I don't re-connect the Retrode.
The other both adapters (N64 & GB/GBA) work fine (this one with the plastic shell aka Version 2)
I tried it out on both Windows XP Professional 32Bit and on Windows 7 Home Premium 64Bit.
Always the same result.
Did anyone have the SMS plugin and know whats going wrong?

PS: Games are cleaned before, tested multiple games, multiple times
PPS: Also tested it now with my Retode 1 (FW: 0.17c), same result :-(

PPPS, Matthias_H: Stickied so other SMS users can find this thread more easily. Please find a Retrode 2 firmware under https://www.retrode.com/files/firmware/Retrode2-v0.18c-alpha3.zip, and let me know how it works for you. In case you want to test it on a Retrode 1 too, please let me know and I will compile a version for it.
« Last Edit: 13/Apr/2013 07:06:33 PM by Matthias_H »

Offline Matthias_H

  • Retrode Forum Techie
  • A Retrode Hero
  • *****
  • Posts: 540
  • Karma: +21/-0
    • View Profile
Re: SEGA Master Sytem Plugin Adapter Problem
« Reply #1 on: 23/Mar/2013 02:58:47 PM »
Sounds a bit like the problem Muzer was experiencing with his A2600 plug-in. I'll investigate.
http://www.retrode.org

I no longer sell the Retrode. For sales inquiries, please contact our friends at DragonBox.

Offline Games Xtreme

  • Baby Retrode
  • *
  • Posts: 10
  • Karma: +2/-0
    • View Profile
    • Games Xtreme's Gaming & Modding
Re: SEGA Master Sytem Plugin Adapter Problem
« Reply #2 on: 24/Mar/2013 01:55:00 AM »
With the other plugins (N64&GB/GBA, second batch, with case) I did't have any problem.
With the "old" plugins I also don't have any problems. Even the first-batch-A2600-Adapter works thanks to Muzer's Firmware update.
Sad that it must be the SMS-Adapter, because it was the plugin I was looking forward the most.  :(

Offline Matthias_H

  • Retrode Forum Techie
  • A Retrode Hero
  • *****
  • Posts: 540
  • Karma: +21/-0
    • View Profile
Re: SEGA Master Sytem Plugin Adapter Problem
« Reply #3 on: 24/Mar/2013 03:56:19 AM »
N64 and GBx have already been tested by hundreds of users; SMS only by two. It may take a few firmware iterations to fix the problem. Any other users experiencing a similar behavior?
http://www.retrode.org

I no longer sell the Retrode. For sales inquiries, please contact our friends at DragonBox.

Offline Toby

  • Baby Retrode
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: SEGA Master Sytem Plugin Adapter Problem
« Reply #4 on: 24/Mar/2013 05:17:25 PM »
I have the same problems with the Master System-Adapter.
As soon as I want to start the rom it disappears.

Offline Retrofan

  • Baby Retrode
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: SEGA Master Sytem Plugin Adapter Problem
« Reply #5 on: 24/Mar/2013 08:34:15 PM »
I've received my SMS Plug-In recently and encountered the same problem. The Retrode will work with the plug-in attached, but as soon as I connect it to a game (Sonic the Hedgehog, PAL-version sold in Germany), both the config file and the rom file will disappear instantly.

Offline Matthias_H

  • Retrode Forum Techie
  • A Retrode Hero
  • *****
  • Posts: 540
  • Karma: +21/-0
    • View Profile
Re: SEGA Master Sytem Plugin Adapter Problem
« Reply #6 on: 25/Mar/2013 03:41:39 AM »
Okay. I just found a game (Action Fighter) for which I get the same problem (100% reproducible with voltage selector at 3.3V, sometimes also at 5V). Let's see if I can get it to run consistently...
http://www.retrode.org

I no longer sell the Retrode. For sales inquiries, please contact our friends at DragonBox.

Offline Games Xtreme

  • Baby Retrode
  • *
  • Posts: 10
  • Karma: +2/-0
    • View Profile
    • Games Xtreme's Gaming & Modding
Re: SEGA Master Sytem Plugin Adapter Problem
« Reply #7 on: 29/Mar/2013 08:22:02 PM »
I've more or less successfully dumped Sonic the Hedgehog [PAL Version] (Please find attached).
I flashed the Retrode 2 with the Firmware 0.17e, the voltage at 5V  and dumped 2 ROMs, first 64KB, the second 128 KB.
After that I tried different games but it falls back to the regular problem.
All other constellations (different voltage & different firmware) gave me the same problem as ever (256 KB ROM size & non-copyable).
At the first dump (64KB) it shows the titlescreen and after that the level select screen. Than the game freezes.
At the second dump (128KB) it only shows the title screen and freezes after that.
On both ROMs it plays the suitable music but the graphics are EXTREMLY buggy.

PS: "other firmwares" means:

    Retrode2-v0.18b_alpha
    Retrode2-v0.18a
    Retrode2-v0.17h-alpha
    Retrode2-v0.17g
    Retrode2-v0.17f
    Retrode2-v0.17d
    Retrode2-v0.17c
    Retrode2-v0.17b

PPS: "different games" means:

-Asterix
-Castle of Illusion starring Mickey Mouse
-Global Gladiators
-Golden Axe
-Klax
-Land of Illusion starring Mickey Mouse
-Sonic 2
-The Flash
-The Lucky Dime Caper starring Donald Duck
-Wonder Boy III: The Dragon's Trap
-Wimbledon

I hope the explanation and the dumps help to understand the problem of the firmware.
« Last Edit: 29/Mar/2013 08:26:55 PM by Games Xtreme »

Offline Matthias_H

  • Retrode Forum Techie
  • A Retrode Hero
  • *****
  • Posts: 540
  • Karma: +21/-0
    • View Profile
Re: SEGA Master Sytem Plugin Adapter Problem
« Reply #8 on: 30/Mar/2013 05:59:21 AM »
Thanks everyone for testing. What a nasty bug! I spent more than 30 hours this week trying to track the issue down and fix it. After upgrading the firmware to the latest USB library version (a major step!) and making a few subtle adjustments around the SMS routine, I now have all my SMS carts running smoothly on a Retrode 2 at 5V under both a WinXP machine and a MacBook Air 2010 running OS X Mountain Lion. The titles I tested are:

The Lucky Dime Caper starring Donald Duck
Ace of Aces
Captain Silver
Pro Wrestling
Out Run
Casino Games
World Soccer
Action Fighter

Please find a Retrode 2 firmware under https://www.retrode.com/files/firmware/Retrode2-v0.18c-alpha.zip, and let me know how it works for you. In case you want to test it on a Retrode 1, please let me know and I will compile a version for it.
http://www.retrode.org

I no longer sell the Retrode. For sales inquiries, please contact our friends at DragonBox.

Offline Games Xtreme

  • Baby Retrode
  • *
  • Posts: 10
  • Karma: +2/-0
    • View Profile
    • Games Xtreme's Gaming & Modding
Re: SEGA Master System Plugin Adapter Problem
« Reply #9 on: 30/Mar/2013 11:25:45 AM »
I've now dumped all games with the new firmware (v0.18c-alpha) at 5V. All games were copyable.

The results are the following:

-Asterix - HWB switching - working - 512KB
-Castle of Illusion starring Mickey Mouse - working - 256KB
-Global Gladiators - working - 256KB
-Golden Axe - HWB switching - working - 512KB
-Klax - HWB switching - not working - 128KB
-Land of Illusion starring Mickey Mouse - HWB switching - working - 512KB
-Ninja Gaiden - working - 256KB
-Sonic 1 - working - 256KB
-Sonic 2 - HWB switching - working - 512KB
-The Flash - working - 256KB
-The Lucky Dime Caper starring Donald Duck - working - 256KB
-Wonder Boy III: The Dragon's Trap - working - 256KB
-Wimbledon - working - 256KB

PS: none of them are in "GoodSMS v3.2.0" for whatever reason

PPS: non-working "Klax"-ROM [TmrSega3.2501.sms] (Please find attached)

Offline Matthias_H

  • Retrode Forum Techie
  • A Retrode Hero
  • *****
  • Posts: 540
  • Karma: +21/-0
    • View Profile
Re: SEGA Master System Plugin Adapter Problem
« Reply #10 on: 30/Mar/2013 06:25:09 PM »
Ah, wonderful, thank you. The size detection should be easy to fix; hope to get it done by the end of today. Do any of these titles have SRAM too?
http://www.retrode.org

I no longer sell the Retrode. For sales inquiries, please contact our friends at DragonBox.

Offline Games Xtreme

  • Baby Retrode
  • *
  • Posts: 10
  • Karma: +2/-0
    • View Profile
    • Games Xtreme's Gaming & Modding
Re: SEGA Master System Plugin Adapter Problem
« Reply #11 on: 31/Mar/2013 12:21:43 AM »
No, none of my games have SRAM.
The only games I know that have SRAM are the following, which I unfortunately don't have in my collection

  • Golden Axe Warrior
  • Golfamania
  • Miracle Warriors: Seal of the Dark Lord
  • Monopoly
  • Penguin Land
  • Phantasy Star
  • Ultima IV: Quest of the Avatar
  • Ys: The Vanished Omens

PS: Maybe some other Users can test this. Does anyone of you guys have at least one of the games above to test?

Offline Matthias_H

  • Retrode Forum Techie
  • A Retrode Hero
  • *****
  • Posts: 540
  • Karma: +21/-0
    • View Profile
Re: SEGA Master System Plugin Adapter Problem
« Reply #12 on: 31/Mar/2013 05:17:22 AM »
New firmware - size detection should now work as it should. Also, added SRAM reading, but completely untested.

https://www.retrode.com/files/firmware/Retrode2-v0.18c-alpha2.zip
http://www.retrode.org

I no longer sell the Retrode. For sales inquiries, please contact our friends at DragonBox.

Offline Games Xtreme

  • Baby Retrode
  • *
  • Posts: 10
  • Karma: +2/-0
    • View Profile
    • Games Xtreme's Gaming & Modding
Re: SEGA Master System Plugin Adapter Problem
« Reply #13 on: 31/Mar/2013 02:01:27 PM »
I now dumped all games that I have again with the new firmware v0.18c-alpha2 and here are the (sad) results:
(I didn't use HWB switching to test the auto-detection routine)

-Asterix - no autodetection of the ROM size - not working - 256KB
-Castle of Illusion starring Mickey Mouse - working - 256KB
-Global Gladiators - not working - 256KB
-Golden Axe - no autodetection of the ROM size - partially working - 256KB
-Klax - autodetection of the ROM size - not working - 128KB
-Land of Illusion starring Mickey Mouse - no autodetection of the ROM size - partially working - 256KB
-Ninja Gaiden - not working - 256KB
-Sonic 1 - not working - 256KB
-Sonic 2 - no autodetection of the ROM size - not working - 256KB
-The Flash - working - 256KB
-The Lucky Dime Caper starring Donald Duck - working - 256KB
-Wimbledon - not working - 256KB
-Wonder Boy III: The Dragon's Trap - not working - 256KB

PS: If you need the dumps to look into them, let me know.
PPS: "GoodSMS v3.2.0" also "didn't like" them

Offline Matthias_H

  • Retrode Forum Techie
  • A Retrode Hero
  • *****
  • Posts: 540
  • Karma: +21/-0
    • View Profile
Re: SEGA Master System Plugin Adapter Problem
« Reply #14 on: 31/Mar/2013 05:16:51 PM »
Okay :( Thanks for testing. I did, of course, make a few more changes to the code than just the size detection, so it appears I broke some other thing along the way. Could you please send me the non-working Asterix, Golden Axe and Sonic 2?
http://www.retrode.org

I no longer sell the Retrode. For sales inquiries, please contact our friends at DragonBox.