Author Topic: Error Code 43 on USB Device, cannot open USB port  (Read 10328 times)

Offline Matthias_H

  • Retrode Forum Techie
  • A Retrode Hero
  • *****
  • Posts: 546
  • Karma: +21/-0
    • View Profile
Re: Error Code 43 on USB Device, cannot open USB port
« Reply #15 on: 09/Dec/2015 02:39:19 PM »
Well. I guess if this only concerns firmware updates (and considering how rare those are), you'll just have to find a Win8 machine every couple of years.
http://www.retrode.org

I no longer sell the Retrode. For sales inquiries, please contact our friends at DragonBox.

Offline pierre

  • Baby Retrode
  • *
  • Posts: 1
  • Karma: +2/-0
    • View Profile
Re: Error Code 43 on USB Device, cannot open USB port
« Reply #16 on: 30/Dec/2015 08:25:34 PM »
Hi!

I had this problem too, looks like it is a common problem not limited to the retrode.
Following the instructions there brought me fúrther, problem is described there:
 
http://blogs.msdn.com/b/usbcoreblog/archive/2013/11/26/why-does-my-usb-device-work-on-windows-8-0-but-fail-on-windows-8-1-with-code-43.aspx, go straight to the Workaround! You can search for the following sentence: "To apply the workaround for a specific device, add a REG_DWORD value named SkipBOSDescriptorQuery that"

(Though I am not done with flashing yet, at least no usb error and usb connection can be opened.)

edit: Flashing is now working.

« Last Edit: 31/Dec/2015 09:41:25 AM by pierre »

Offline Pat1986

  • Baby Retrode
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Re: Error Code 43 on USB Device, cannot open USB port
« Reply #17 on: 08/Jan/2016 02:11:42 PM »
Hi!

I had this problem too, looks like it is a common problem not limited to the retrode.
Following the instructions there brought me fúrther, problem is described there:
 
http://blogs.msdn.com/b/usbcoreblog/archive/2013/11/26/why-does-my-usb-device-work-on-windows-8-0-but-fail-on-windows-8-1-with-code-43.aspx, go straight to the Workaround! You can search for the following sentence: "To apply the workaround for a specific device, add a REG_DWORD value named SkipBOSDescriptorQuery that"

(Though I am not done with flashing yet, at least no usb error and usb connection can be opened.)

edit: Flashing is now working.

Thank you! That did the trick for me as well. :)