Author Topic: Insufficient Space to Copy Back GB Save  (Read 1615 times)

Offline MasterOfPuppets

  • Sgt. Retrode
  • ***
  • Posts: 103
  • Karma: +2/-0
    • View Profile
Insufficient Space to Copy Back GB Save
« on: 05/Jun/2016 02:39:12 AM »
I've had this error for a while now (not just with version 19). When I try to copy back a Game Boy save (tried Pokemon Gold today), it says there's not enough space and I need to free up 32kb of room (the size of the save in this case). I've unchecked the read-only and archive options on the save file and it still does it. I tried editing the save with a hex editor and the change didn't stay. Any ideas?

Offline Matthias_H

  • Retrode Forum Techie
  • A Retrode Hero
  • *****
  • Posts: 546
  • Karma: +21/-0
    • View Profile
Re: Insufficient Space to Copy Back GB Save
« Reply #1 on: 06/Jun/2016 08:50:40 AM »
Which hex editor? Did you make sure to save the file in place (disable backup option where editor renames old file and creates a new one?)

Also, http://www.retrode.org/documentation/troubleshooting/troubleshooting-saving-files-to-the-retrode-does-not-work/
http://www.retrode.org

I no longer sell the Retrode. For sales inquiries, please contact our friends at DragonBox.

Offline MasterOfPuppets

  • Sgt. Retrode
  • ***
  • Posts: 103
  • Karma: +2/-0
    • View Profile
Re: Insufficient Space to Copy Back GB Save
« Reply #2 on: 07/Jun/2016 02:24:06 AM »
HxD. I'll try it again and see if it works.

Offline Wannado

  • Junior Retrode
  • **
  • Posts: 98
  • Karma: +13/-0
    • View Profile
Re: Insufficient Space to Copy Back GB Save
« Reply #3 on: 19/Jun/2016 09:25:50 PM »
... I've unchecked the read-only and archive options on the save file ...

The Retrode does not care about the file's read-only attribute, only sets it to tell the host (PC, ...) that writing to the file is pointless. :)

To make the save really writable, you must set "[sramReadonly] 0" in RETRODE.CFG.

Offline MasterOfPuppets

  • Sgt. Retrode
  • ***
  • Posts: 103
  • Karma: +2/-0
    • View Profile
Re: Insufficient Space to Copy Back GB Save
« Reply #4 on: 22/Jun/2016 05:19:58 PM »
Sorry for the delay. I tried it again today (just overwriting, no hex) with a different game, Zelda Oracle of Seasons, and it gave the same error. The save size is only 8kb. SramReadOnly is set to 0.
« Last Edit: 22/Jun/2016 05:29:48 PM by MasterOfPuppets »

Offline Wannado

  • Junior Retrode
  • **
  • Posts: 98
  • Karma: +13/-0
    • View Profile
Re: Insufficient Space to Copy Back GB Save
« Reply #5 on: 01/Jul/2016 09:56:23 PM »
The save data can only be changed by overwriting the Retrode's save file in place. However, some copy commands, when asked to overwrite file X, instead create a new file Y, then delete X, and finally rename Y to X. The Retrode does not support this or similar procedures, as they would require a lot of buffer memory.

The same restriction applies to the Retrode's config file.

I expect the following method of overwriting a file on the Retrode to be reliable:
  • "Delete" that file on the Retrode. I repeat: on the Retrode. Note that it must be a permanent deletion command. Moving the file to the "recycle bin" will not work.
  • Copy your file to the Retrode. Since the only free space is that of the deleted file, the data should go exactly where it is supposed to.

Warnings:

  • The name of the new file does not matter to the Retrode. If you delete the save file, any new file will overwrite the save data.
  • Do not delete more than one Retrode file at once.
  • Do not edit another Retrode file while one is deleted.

Other notes:

  • After connecting the Retrode, please verify that the read-only attribute of the Retrode's save file is already unchecked. This is to confirm that sramReadonly 0 has really taken effect. If it didn't, try editing the config file as described above.
  • If you look at a file after editing it, the host usually shows you cached data. You must safely remove / unmount and reset the Retrode to see if the written data was really stored.
  • When using HxD to edit a file on the Retrode, make sure the option to create backup (BAK) files is unchecked.

Offline MasterOfPuppets

  • Sgt. Retrode
  • ***
  • Posts: 103
  • Karma: +2/-0
    • View Profile
Re: Insufficient Space to Copy Back GB Save
« Reply #6 on: 01/Jul/2016 10:26:54 PM »
Thanks! I'll try your suggestions the next time I need to copy a save.