Author Topic: Retrode won't read SRAM for SNES Enix games (7th Saga, Brain Lord, Robotrek)  (Read 1205 times)

Offline ProgrammerXIII

  • Baby Retrode
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
As stated in the title, the Retrode doesn't seem able to read the SRAM for certain Enix games on the Super Nintendo. The ROM reads fine, but the SRAM file is just filled with Fs (see attached). I'm using a Retrode 2 with the default configuration file, and I've tried this with firmware v0.19 and v0.21. I haven't noticed this problem with any other games.

I've seen this problem mentioned in other threads (here and here), but without any kind of resolution.

Has anyone discovered a workaround for this issue? Is this problem something that could be addressed with a future firmware update? I'd be glad to volunteer my time to work on this; I have some background in computer programming and electrical engineering, so please let me know what I could do to help.

Offline Wannado

  • Sgt. Retrode
  • ***
  • Posts: 104
  • Karma: +13/-0
    • View Profile
Since one of the threads you linked refers to Brain Lord: A long time ago, justin89 provided a patch which he said includes "a way to read/write SNES Brain Lord and Robotrek saves" (among other things). I didn't manage to merge that patch yet.

A lot has changed in the firmware architecture since the revision that justin89's patch is based on, so the merge isn't trivial.

And there, I'm right out of time for another week.

Offline ProgrammerXIII

  • Baby Retrode
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
It's been a while since I opened this topic, but I'd just like to clarify that this should no longer be an issue as of firmware v0.22. User skaman has been doing incredible work expanding the functionality of the Retrode.

Unless I've missed something, the latest firmware is covered by this post. If you need instructions on how to update your Retrode's firmware, start here.