Author Topic: Trouble Updating to v23  (Read 80 times)

Offline WolfBoy980

  • Baby Retrode
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Trouble Updating to v23
« on: 18/Nov/2017 07:10:02 AM »
I've been following the updating steps like the Bible, but I can't seem to get the right results. I've installed the device properly using Flip, and the Retrode 2 enters DFU mode perfectly. But when I attempt to connect to the device, Flip can't open the device!

I updated the driver so the device is named AT90USB64. But from there it gets messy...
Some users have reported that their device updates fine with Flip's AT90USB646 driver detection, but i'm not getting scratch. I've uninstalled and reinstalled the Flip software multiple times and attempted updating the Retrode's DFU driver to only get messages saying I have the best driver installed already.I just can't get it to work, I can't seem to find a solution from anyone else!

I saw some users report it was because of driver incompatibility with Windows 10? Is this still true?

Offline skaman

  • Global Moderator
  • Junior Retrode
  • *****
  • Posts: 75
  • Karma: +31/-0
    • View Profile
Re: Trouble Updating to v23
« Reply #1 on: 18/Nov/2017 09:54:20 AM »
This thread might be of help:  http://forum.retrode.org/index.php/topic,134.0.html

Read from Reply #14 to the end.

Offline RazorX2014

  • Junior Retrode
  • **
  • Posts: 88
  • Karma: +1/-0
    • View Profile
Re: Trouble Updating to v23
« Reply #2 on: 18/Nov/2017 09:18:23 PM »
i enter DFU mode by doing the following, it may help:
hold down RESET then while holding it down, hold down HWB then let go of RESET then let go of HWB

Offline kjorteo

  • Baby Retrode
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Trouble Updating to v23
« Reply #3 on: 18/Nov/2017 09:48:46 PM »
I ultimately wasn't able to get the device recognition for firmware update mode to work in Windows.  Every time I tried entering DFU mode, rather than recognizing it as a new device (and prompting me to install drivers, etc.,) it threw a prompt that the USB device had malfunctioned and please reconnect it.  I was able to ignore that and install the drivers in the newfound "Unknown Device" in Device Manager, but I never was able to do so in such a way that FLIP could open the connection.

Instead, since I have a laptop with Linux on it, I tried hooking the Retrode up to that and following those firmware update instructions instead.  Those ones ended up working perfectly on the first try.

Offline WolfBoy980

  • Baby Retrode
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Trouble Updating to v23
« Reply #4 on: 18/Nov/2017 10:05:29 PM »
This thread might be of help:  http://forum.retrode.org/index.php/topic,134.0.html

Read from Reply #14 to the end.

You mean this?

"Workaround
(Note that this workaround was added in the Windows update that was released on  07/08/2014. If you are applying this update within few weeks of this date, you will need to download and manually install the update from www.microsoft.com/.../details.aspx.)
To apply the workaround for a specific device, add a REG_DWORD value named SkipBOSDescriptorQuery that has a value of 1 to the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\usbflags\vvvvpppprrrr
(where vvvv is the device's Vendor ID, pppp is the device's Product ID, and rrrr is the device's Revision number. You can get the VID/PID/REV numbers from the device manager's details tab. This number is encoded in the HardwareIDs of the device)
1. Click Start, click Run, type regedit in the Open box, and then click OK .
2. Locate and then click the following subkey in the registry:
        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\UsbFlags
3. On the Edit menu, point to New, and then click Key.
4.Type the name of the new key in the following form:
        vvvvpppprrrr
        where
        vvvv is a 4-digit hexadecimal number that identifies the vendor (idDevice from the USB Deviceescriptor),
        pppp is a 4-digit hexadecimal number that identifies the product (idVendor from the USB Device Descriptor)
        rrrr is a 4-digit binary-coded decimal number that contains the revision number of the device
              (bcdDevice from the USB Device Descriptor).
5. On the Edit menu, point to New, and then click DWORD (32-bit) Value.
6. Type SkipBOSDescriptorQuery for the name of the DWORD Value, and then press ENTER.
7. Right-click SkipBOSDescriptorQuery, and then click Modify.
8. In the Value data box, type 1 , and then click OK.
9. Exit Registry Editor.
10. Unplug and re-plug the device for the workaround to take effect."

Did that, nothing changed. Pictures for proof in the case you might see something I did wrong.

https://isxehg.bn1304.livefilestore.com/y4pMEUi0zve5SOkYMVWYpkAA5MDR6dsFZTGogZVqCEIxnmfpY484s2AY_rPGYQpxzUvd6eyR8TfjhYbfGNxd1Px604nvgNlD6fL4Hy5r1LkRzYmPfL4eTyZErRWDaIIFsoy8Kf1N75twL4wLWupBK_KRzxKSh3YJ6d2_uxUDXERR4Hyz7Ztic0rMPyQWHTz-ERFU56gpHXbSqXXKSJoj69ORQ/regeditretrode.PNG?psid=1

https://isxdhg.bn1304.livefilestore.com/y4poZvfjMRP-dsltAxvlWtRN0xsMQ_GY4DoAJmmvgnufZcg2zgvFjKajHV0HYB6POg9tu8HhHSgIPoicKdtMMCF0_TC5kqQJY5xtx4NncFbRSS2LA0i-Etg9KSqtv6Lsj9ZFVyURuS25m8M4UYXxntmrpsDglqrBCLzUEAp28nxc2UI8-U_Vvigh0f-uoM2u6Pi5vvUTeBtx9Poq9_DzDwzEQ/devicemanagerretrode.PNG?psid=1

Apologies for providing two links and two attachments to the photos instead of an embedding. The photo button doesn't seem to be working on Microsoft Edge or something.