Recent Posts

Pages: 1 2 [3] 4 5 ... 10
Support / Re: Gameboy saves no longer transfering to the Retrode
« Last post by Nori on 02/Apr/2018 03:43:47 PM »
Thanks a bunch Wannado. I'm going to try that out! :)
Support / Re: Gameboy saves no longer transfering to the Retrode
« Last post by skaman on 02/Apr/2018 05:13:26 AM »
Ok.  So MBC2 saves are the issue.
Support / Re: Gameboy saves no longer transfering to the Retrode
« Last post by Wannado on 01/Apr/2018 08:21:19 PM »
Hi Nori, I just noticed that I have the FFA game, too, only with its European title "Mystic Quest".

The game's mapper chip has exactly 512 half-bytes of RAM built-in. They appear as 512 bytes, with only the lower half of each byte having actual storage on the chip. The Retrode detects that correctly.

I'm using the KiGB emulator, version 2.05, which too creates an 8 kiB save file for that game. The game still only uses the first 512 bytes of it, so the rest of the file is garbage (it's quite obvious in the file that I had once saved).

Long story short, to copy your emulator save game of FFA to the cartridge, try using a hex editor to copy only the first 512 bytes from the emulator save file to the Retrode save file.

Note: IIRC, the Retrode shows the unused upper half of each byte as hex F while KiGB seems to prefer 0. This should have no effect when copying from the emulator file to the Retrode file. I don't remember if it's a problem when copying in the other direction, from the Retrode to the emulator file.
General Discussion / Re: Any chance of Super Street Fighter II Genesis?
« Last post by Lowe0 on 28/Mar/2018 01:12:19 AM »
Awesome - thanks!
General Discussion / Re: Virtual Boy SRAM Support
« Last post by skaman on 27/Mar/2018 04:13:22 AM »
I looked for a pinout that would support both SRAM and Hyper Fighting.

Unfortunately, support for both is not possible due to a lack of available control pins on the Retrode.

I'm going to stick with my current plugin design with support for the SRAM.

If anyone wants to read out Hyper Fighting, then the original pinout needs to be modified with the following pins:
Code: [Select]
Sega          Signal            VB
B9              a21             14
B10             a22             12
B11             a23             10

If the cart is not detected, then use FW v0.25 with forceSystem set to "vboy" and forceSize set to "32".  The ROM should be identified as FightingDemo.vb.
General Discussion / Re: PC Engine/Turbografx plug in?
« Last post by skaman on 25/Mar/2018 09:17:24 PM »
Here are pics of the Plugin PCB in an aftermarket SNES shell:

Support / Re: Gameboy saves no longer transfering to the Retrode
« Last post by Nori on 25/Mar/2018 08:28:46 PM »
Thank you Wannado. I tried that and unfortunately it doesn't work. When I delete the save file it says the Retrode has 512b of free space. The save I had from before was 8kb, and so I still get the message from the image in the initial post. If I save a game and copy that 512b file out of the retrode, delete it from the retrode, and move back that recent one will transfer back and the newly created save will still be there.

In the past all Game Boy games I had transferred saves out from the cartridge to the computer have worked, and a few that started on the computer (via emulator) to the original cart worked as well. From all appearances all this still happens and functions properly except this one title. Thinking back I can't even be sure that this game's save had ever been back and forth with the Retrode. It might have been only through an emulator. Still it's odd since other games using the same emulator did work being sent back, and I checked the rom version I have for this game and it seems to match "Final Fantasy Adventure (U)" which should be the us version of the game, which is the same as the cartridge itself.
Support / Re: Gameboy saves no longer transfering to the Retrode
« Last post by Wannado on 25/Mar/2018 07:58:41 PM »
Edit: Nori posted reply #3 while I was still typing the text below. So the problem seems to be the file size and not what I had guessed.

The problem might be this: For the transfer to work, the save file that exists on the Retrode must be overwritten "in place": Open file X, overwrite data, close file X.
Your PC might instead be trying to create a new file Y, fill it with the data, close file Y, delete file X and finally rename file Y to X.

The latter does not work with the Retrode. It fails in the first step (create new file Y) because there is no free space. The Retrode has not enough memory to buffer a temporary file, and it cannot tell where else the data should go (config? save? ...).

Please try the following and tell us if it worked:
First, check that the save file on the Retrode is exactly the same size as the save file that you want to copy over.
If the sizes match, "delete" the save file on the Retrode. This will only remove the file's directory entry and mark the area where the file is mapped into the Retrode's virtual volume as free. The actual save on the cartridge will not be harmed.
Finally, copy your new save file to the Retrode. This should cause the PC to write the data to the proper area.

Warning: In the time between deleting the Retrode save file and copying the new one, do not edit anything else on the Retrode.
Support / Re: Gameboy saves no longer transfering to the Retrode
« Last post by Nori on 25/Mar/2018 07:37:24 PM »
Ok I tried with Wario Land: Mario Land 3 and it works fine. So the problem might just be Seiken Densetsu aka Final Fantasy Adventure. My cart is the US ntsc version. and the save was from the same version.

When I start a new game, save and transfer that save it gives me a 1kb file (or in properties it even says 512 bytes). Which is weird. The previous was 8kb and so it can't be transfered back. Not too sure what happened, but I don't want to waste your time for a single game. Thanks Skaman, everything you do has been so awesome for the retrode.
Support / Re: Gameboy saves no longer transfering to the Retrode
« Last post by Nori on 25/Mar/2018 07:32:27 PM »
Thanks for the reply. Actually I reverted to .20 to try, which was the one I had previously, and it's also not working. So for now I'm back in .24. Truth is I hadn't done game boy save transfers since .17 or .18 I think. Back then the save format was .srm.

I'm going to try other games than Final Fantasy Adventure just to make sure it's not just this one game.
Pages: 1 2 [3] 4 5 ... 10