Recent Posts

Pages: 1 ... 8 9 [10]
General Discussion / Re: Trouble Updating to v23
« Last post by WolfBoy980 on 18/Nov/2017 10:05:29 PM »
This thread might be of help:,134.0.html

Read from Reply #14 to the end.

You mean this?

(Note that this workaround was added in the Windows update that was released on  07/08/2014. If you are applying this update within few weeks of this date, you will need to download and manually install the update from
To apply the workaround for a specific device, add a REG_DWORD value named SkipBOSDescriptorQuery that has a value of 1 to the following registry subkey:
(where vvvv is the device's Vendor ID, pppp is the device's Product ID, and rrrr is the device's Revision number. You can get the VID/PID/REV numbers from the device manager's details tab. This number is encoded in the HardwareIDs of the device)
1. Click Start, click Run, type regedit in the Open box, and then click OK .
2. Locate and then click the following subkey in the registry:
3. On the Edit menu, point to New, and then click Key.
4.Type the name of the new key in the following form:
        vvvv is a 4-digit hexadecimal number that identifies the vendor (idDevice from the USB Deviceescriptor),
        pppp is a 4-digit hexadecimal number that identifies the product (idVendor from the USB Device Descriptor)
        rrrr is a 4-digit binary-coded decimal number that contains the revision number of the device
              (bcdDevice from the USB Device Descriptor).
5. On the Edit menu, point to New, and then click DWORD (32-bit) Value.
6. Type SkipBOSDescriptorQuery for the name of the DWORD Value, and then press ENTER.
7. Right-click SkipBOSDescriptorQuery, and then click Modify.
8. In the Value data box, type 1 , and then click OK.
9. Exit Registry Editor.
10. Unplug and re-plug the device for the workaround to take effect."

Did that, nothing changed. Pictures for proof in the case you might see something I did wrong.

Apologies for providing two links and two attachments to the photos instead of an embedding. The photo button doesn't seem to be working on Microsoft Edge or something.
General Discussion / Re: Trouble Updating to v23
« Last post by kjorteo on 18/Nov/2017 09:48:46 PM »
I ultimately wasn't able to get the device recognition for firmware update mode to work in Windows.  Every time I tried entering DFU mode, rather than recognizing it as a new device (and prompting me to install drivers, etc.,) it threw a prompt that the USB device had malfunctioned and please reconnect it.  I was able to ignore that and install the drivers in the newfound "Unknown Device" in Device Manager, but I never was able to do so in such a way that FLIP could open the connection.

Instead, since I have a laptop with Linux on it, I tried hooking the Retrode up to that and following those firmware update instructions instead.  Those ones ended up working perfectly on the first try.
General Discussion / Re: Trouble Updating to v23
« Last post by RazorX2014 on 18/Nov/2017 09:18:23 PM »
i enter DFU mode by doing the following, it may help:
hold down RESET then while holding it down, hold down HWB then let go of RESET then let go of HWB
General Discussion / Re: N64 Save Support (FW v0.23)
« Last post by kjorteo on 18/Nov/2017 08:38:08 PM »
Can someone please verify whether Pokemon Snap works on their end?  I have a cart I just cannot for the life of me seem to confirm.

* Tested and confirmed the save data is still valid and present in the actual cart on an actual N64
* Retrode appeared to read the cart just fine; the .z64 and .fla files were right there and transferred over to PC without incident
* I'm no expert, but peering at the .fla file in a hex editor sure looks like there's data in there and that it's not just an empty file or full of 00/FF or whatever.
* Yet both 1964 and Project 64 act like I've fed it a completely blank file when I load the game, in that there's no "Continue" option on the main menu, etc.
* Yes, I unchecked Read Only and made sure it was on 3.3 volts.
* Possibly a .fla issue?  I am afraid I can't test this with any other .fla saves, as the only other game I have that uses .fla is Pokemon Stadium (which doesn't appear to have a save file even when I test the physical cart in the physical system.)  My other games all work fine, but they also all use .eep.

I've attached the .fla file for reference.  If my attempts to parse the hex editor view are correct and this is a valid data file, then there appears to be some sort of issue with getting either of the emulators I tried to read it.  If it's not, then something is up on the Retrode reading/transferring end, since this is definitely a real and working save on the physical system.

Thank you so much for any assistance you can provide!
General Discussion / Re: Trouble Updating to v23
« Last post by skaman on 18/Nov/2017 09:54:20 AM »
This thread might be of help:,134.0.html

Read from Reply #14 to the end.
General Discussion / Trouble Updating to v23
« Last post by WolfBoy980 on 18/Nov/2017 07:10:02 AM »
I've been following the updating steps like the Bible, but I can't seem to get the right results. I've installed the device properly using Flip, and the Retrode 2 enters DFU mode perfectly. But when I attempt to connect to the device, Flip can't open the device!

I updated the driver so the device is named AT90USB64. But from there it gets messy...
Some users have reported that their device updates fine with Flip's AT90USB646 driver detection, but i'm not getting scratch. I've uninstalled and reinstalled the Flip software multiple times and attempted updating the Retrode's DFU driver to only get messages saying I have the best driver installed already.I just can't get it to work, I can't seem to find a solution from anyone else!

I saw some users report it was because of driver incompatibility with Windows 10? Is this still true?
General Discussion / Re: Need a bit of help making a Mark III adapter
« Last post by hadess on 17/Nov/2017 11:41:50 AM »
Just needs a nice sticker now :)

(I've made such a sticker for the SMS/GG combo, after cutting up a Megadrive case as well, I'll post it once I've actually printed it out for testing)
General Discussion / Re: Need a bit of help making a Mark III adapter
« Last post by skaman on 17/Nov/2017 11:36:44 AM »
Here's a few pics with a handcut shell.

One nice thing with the Mark III Plugin is that the Card Catcher works with it.  I've tested a Sega MyCard and a Sega Card.

General Discussion / Re: N64 Save Support (FW v0.23)
« Last post by Eureka on 17/Nov/2017 03:01:54 AM »
The Majora cart is the original NTSC release with the lenticular label. "Savereadonly" is already set to 1. I'm using Retrode 2 and the plugin built specifically for N64 carts (the one that says "Plug-In 64" on the label). I don't understand the "files" question.

I put the saves in the "Save" folder of Project64; it's where it gets them from. But I get a "Failed to open EEPROM" message when I try to use them.

You mentioned something about setting the voltage to 3.3V; that is something I forgot to do the first time. But when I dumped the saves again on the correct setting, I got the same results. The Majora cart did finally detect a save, though.

Of course it's an .FLA which means I can't test it immediately. That save-altering program you linked to is all Greek to me -- I have little experience with command line programs so I don't know how to use it. I do know that the .EEP files don't work.

Sorry,  I missed this reply.

Now that you can see the Majora's Mask save, you'll need to saveswap it to run on PJ64.

When using save files on PJ64:
1)  Make sure that the save file is in the PJ64 SAVE folder and that it is properly named.
2)  Make sure that the READ-ONLY attribute is unchecked on the save file in the SAVE folder.

Good Luck!
The Read-Only box was the big problem. Now the saves work. Thanks very much.

General Discussion / Re: N64 Save Support (FW v0.23)
« Last post by Knight of Time on 15/Nov/2017 10:56:43 PM »
This is wonderful, thank you so much Skaman.

Perhaps someday I'll buy one of the N64 plugins for my Retrode2 before I purchase a Nintendo 64 (there are some games I'm definitely planning to buy to test with the plugin, and one is definitely going to be Mario Kart 64).  I think 2018 will be that time.
Pages: 1 ... 8 9 [10]