Recent Posts

Pages: 1 [2] 3 4 ... 10
General Discussion / Re: Compatible Game Listing for GBX/N64/SMS
« Last post by speedyjohnny on 04/Jan/2019 08:04:02 AM »
I've seen some of you mention forcing a game to be a particular size. I'm testing Kingdom Hearts for the Game Boy Advance and it is showing as only 0 bytes, and obviously does not work. Any suggestions?  I don't know how to change a file size... or if that's even possible.
General Discussion / Re: SEGA SMS/GG Firmware (FW v0.24)
« Last post by speedyjohnny on 04/Jan/2019 06:58:15 AM »
I probably sound like a newbie, but I just finished installing the latest Retrode 2 firmware, and it has not solved the problem I'm having with getting Zaxxon 3D from the Sega Master System to load the ROM file. All I get is NoName.ngp

But I see you have a firmware update specifically for the Master System plugin. Can anyone explain to me or send me the link of how to install it?

Thank you.
Support / Re: Retrode 2 not recognising N64 plugin
« Last post by Secadary on 03/Jan/2019 04:08:16 AM »
I have no words to thank you.
General Discussion / Re: DIY SMS/Game Gear Plug-in?
« Last post by Secadary on 03/Jan/2019 04:07:27 AM »
You have been very helpful
Thank you so much! I was able to find the correct rom size, and it dumped correctly after setting forceSize to 8 and forceSystem to mdrv
The first thing I'd do is try to get more information to narrow things down.

For example, see if you can find solid information on whether the emulator you're trying can play a known-good dump of that specific game.  If not, or if you can't be sure, try to find another emulator which is confirmed to work with known good dumps of it.

I've only ever dumped three ROMs for Genesis with my Retrode (Sonic 2, Sonic & Knuckles, and Sonic 2 & Knuckles), but I know Gameboy Advance ROMs are susceptible to overdump, since they don't specify their size internally. Maybe something about the cart's header is confusing the Retrode into dumping the wrong range of memory addresses.

Check the sizes listed on dat-o-matic to see if what you're dumping is the right size.

If it's too big, try truncating the file and re-hashing it. If it's too small, try using the Retrode option to override auto-detection and force a dump size. (You may need to dump more and then truncate the result, since the retrode's forced dump sizes don't let you specify a size down to individual bytes.)

Check sites like dat-o-matic for evidence of either the hash you have now or any hashes you get from experimenting with size-forcing and truncating. (If nothing else, maybe you'll find dat-o-matic reporting that it's a broken dump that various members managed to independently confirm as broken.)

Also, I can't endorse piracy, but, if you have a way to get a known good dump through other means, you could try comparing the contents of the two files in various ways to see if you can identify contents of one file within the other, but incomplete or misaligned somehow.
Hi. I have a copy of Felix the Cat for the Genesis that I'm trying to dump, but I can't get it to dump properly for some reason.

The cartridge itself works fine on a real Genesis, but when I try to dump it with my Retrode 2 and run it on an emulator I just get a blank screen. I get the exact same result every time I try to dump it (I always get the same checksum when I generate one after dumping the game), and I know for a fact that the Retrode is dumping something from the game as I can see some notes from the developer if I open the rom with a hex editor.

I was able to find an MD5 checksum for this game, but it doesn't match my attempts at dumping it unfortunately

I was able to dump another unlicensed game with the same board just fine using my Retrode 2, but while that game has a chip, this one has a glob top.
Here's a photo of the board for two games, the one on the right is the one I can't dump

Does anyone know how I might be able to get this game dumped, or perhaps patch it? (I've read that some unlicensed games need to be patched before they can be emulated, but I couldn't find anything for this game)
Support / Retrode 2 not displaying ROM or dummy file [SOLVED]
« Last post by billy.wade on 19/Dec/2018 11:51:39 PM »
I upgraded to the 25a firmware, and at first it was running fine. However, for some reason, it stopped displaying a ROM file entirely. This wouldn't be abnormal if it was showing a romimage.dat file still, but it's showing no file instead, only showing the config file. I figure it's an easy fix I just don't know about. What should I do?

I tried opening the Retrode folder as an administrator, and the games started showing up. From there I set the permissions to editable for all users and now I can access from lower level user privileges.

My guess is that what happened is that because I had to write firmware to it as a superuser, it just wouldn't display to lower users, but I have no concrete reasons why I couldn't use it until now.
General Discussion / Re: SEGA SMS/GG Firmware (FW v0.24)
« Last post by Nori on 12/Dec/2018 05:15:59 PM »
Is anyone ever going to consider making a few GG plugins and selling them at a profit for the less technical of us out there?

Realize this isn't a perfect solution for you, but the SMS plugins ( do still contain the gamegear cart slot holes. So you could get that, buy the gamegear connector from ebay that skaman linked and then make one yourself, or pay someone online to do it for you.

Thanks for sharing the idea.
Support / Re: Connecting official N64 controllers to Retrode 2
« Last post by ssokolow on 10/Dec/2018 12:17:52 AM »
Sorry for the delay in getting back to you and thank you for responding to my forum thread, I don't know why I didn't get a notification email in my inbox as I set up the forum thread to send email notifications as soon as new posts are  uploaded.

Huh. I have the opposite problem. It sends me a weekly digest whether or not there's actually anything to report in the threads I'm watching.
Pages: 1 [2] 3 4 ... 10