Author Topic: Cannot eject Retrode properly + configuration issue.  (Read 3789 times)

Offline Chris

  • Baby Retrode
  • *
  • Posts: 16
  • Karma: +0/-0
Cannot eject Retrode properly + configuration issue.
« on: 06/Jan/2014 12:07:37 AM »
I go to eject my Retrode and it keeps saying a program is still using it even though no programs are open. Also all of my emulators use save files using the extension ".SAV" The Retrode gives the files the extension ".SRM" and marks it read only. As a result if I try playing the game from the cartridge it will not load my save or be able to save to the cartridge. I have tried using the configuration settings but they keep reverting to default; though the configuration settings for forcing file size and cartridge type work. This has also made it more time consuming for me to restore backup saves or move emulator/edited saves to the cartridge as I now must manually rename the .SAV extension to .SRM and manually deselect the read only option on the cartridge's save file. It is not a serious problem, but since I often replace save batteries for other people and offer to restore their save when I am finished (for those who bring their game in before the battery is completely dead) or to recreate their save (to the best of my ability using save editors where possible) it does make the process take a little bit longer.

Offline Matthias_H

  • Retrode Forum Techie
  • A Retrode Hero
  • *****
  • Posts: 555
  • Karma: +21/-0
Re: Cannot eject Retrode properly + configuration issue.
« Reply #1 on: 06/Jan/2014 03:28:14 PM »
Manually removing the "read-only" tick on the file will make it writable to the system but have no effect on the Retrode ; SRAM will still not be written. There's the config option [sramReadOnly] which is set to 1 by default to protect your saves. Set it to 0, and you will be able to save SRAM to cartridges.

I no longer sell the Retrode. For sales inquiries, please contact our friends at DragonBox.