Author Topic: Problem with Genesis saves  (Read 2355 times)

Offline Nori

  • Junior Retrode
  • **
  • Posts: 70
  • Karma: +0/-0
Problem with Genesis saves
« on: 23/Mar/2014 07:26:04 PM »
Hello,

EDITED:
Basically all srm's from Genesis/MD games that I've tried can be backed up and sent back to the carts if unmodified by an emulator.

Any saves either modified from playing on an emu or created via an emu do not transfer back.
With SNES games there is no such problem.

I tried transfering a save from Kega via the command prompt using the type c:\folderx\ShiningForcexxx.srm > i:\ShiningForcexxx.srm

The file does get moved as indicated by the date on file but as soon as I try it in a real console it's back to zero without the save. I have the savewrite to 0 and sega16 to 1 as instructed.

This is very frustrating and disapointing. Any help would be tremendously appreciated.
« Last Edit: 28/Mar/2014 08:28:43 PM by Nori »

Offline Matthias_H

  • Retrode Forum Techie
  • A Retrode Hero
  • *****
  • Posts: 552
  • Karma: +21/-0
Re: Problem with Genesis saves
« Reply #1 on: 25/Mar/2014 09:04:44 PM »
Trying to figure out where exactly you're stuck with all the renaming and copying. So reading Genesis saves off the cart works reliably, and it is only the saving-them-back part that gives you trouble?

Since your emulators output save files twice as big, I could imagine that being part of the problem - second half overwriting the first, or so. Could you mail me two srm files of the same game - one read out through the Retrode and the other one as saved by the emulator?

support at retrode dot org

Thanks,
Matthias
« Last Edit: 25/Mar/2014 09:07:24 PM by Matthias_H »
https://www.retrode.org

I no longer sell the Retrode. For sales inquiries, please contact our friends at DragonBox.

Offline Nori

  • Junior Retrode
  • **
  • Posts: 70
  • Karma: +0/-0
Re: Problem with Genesis saves
« Reply #2 on: 25/Mar/2014 09:57:18 PM »
Thank you for the response. I emailed you and included two saves to Shining Force and one for Ys3, the second one for Shining Force has Kega added to the title to indicate that it came from there.

EDIT:
I have found that the problem comes from saves either modified or created from Kega, or any other emulator. I'm unable to transfer those srm's back to the Retrode. If I backup a save from a cart and transfer that same save unchanged back to the cart that works.

Anyone been able to transfer saves from Kega or Gens to the Retrode?
« Last Edit: 25/Mar/2014 11:00:02 PM by Nori »