Retrode Community Forum

General Category => General Discussion => Topic started by: Failrunner on 17/Aug/2015 12:31:37 AM

Title: Can't save state on Star wars episode 1 racer(N64)
Post by: Failrunner on 17/Aug/2015 12:31:37 AM
I'm using the android Shield TV and for some reason this specific game won't work right with save states but only if I swap games or unmount the storage. If I leave the game in it works fine but I can't put another game in and come back to my game in progress. I just start from the beginning again. The rom will work but if I try playing it off the cart it won't. I cleaned it 3 times with brass polish and alcohol and the save state folder is not on the cart. It's on a usb thumb drive and I have tried the internal storage. Every other game works though.  I've tried the latest mupen64 nightly and mupen64 in retroarch. Oh and my Retrode 2 is on the latest firmware.
Title: Re: Can't save state on Star wars episode 1 racer(N64)
Post by: Haldrie on 17/Aug/2015 12:46:42 PM
The Retrode does not store any data to itself. It only creates a virtual file system to give you access to the rom file and the save file if supported (currently access to saves for the N64 addon cart is not supported in the latest firmware). Anything else you manage to put on there gets deleted when the Retrode is powered off or reset. If you want to keep save states then configure your emulator to use your device's internal storage rather then the Retrode for those files.