Retrode Community Forum

General Category => Support => Topic started by: MarioRPGGeno on 17/Mar/2016 11:31:55 PM

Title: Game Boy plugin not working at all
Post by: MarioRPGGeno on 17/Mar/2016 11:31:55 PM
I've had this problem ever since I recieved my Game Boy plugin for my Retrode. Whenever I try a Game Boy Advance game, it gives me a file called GenericRomInSegaSlot.dat. I've double checked everything, I've made sure the voltage is set to 3.3V, but it still gives me this file. Its the same for original Game Boy games and Game Boy Color games. For them I make sure the voltage is set to 5V. I've tried every game I have but it still gives the same file. I even updated my firmware to 0.18c and opened the adapter with a screwdriver and took a look. Everything inside the plugin looks fine to me. Is there something I'm doing wrong or could I have a faulty plugin?
Title: Re: Game Boy plugin not working at all
Post by: ericbazinga on 18/Mar/2016 04:28:44 AM
Have you tried cleaning the connectors?
Title: Re: Game Boy plugin not working at all
Post by: MarioRPGGeno on 18/Mar/2016 07:33:32 PM
I checked the connectors on the plugin and the games. They play fine in my Game Boy Advance SP or my Game Boy Player.
Title: Re: Game Boy plugin not working at all
Post by: Aleron Ives on 18/Mar/2016 10:28:58 PM
A cart that works fine in a real system doesn't mean it is clean enough to rip. Try using rubbing alcohol and cotton swabs on the contacts. Your cart is ready to rip when the cotton comes back white after touching the contacts. (Every single pin must be clean.)
Title: Re: Game Boy plugin not working at all
Post by: MarioRPGGeno on 19/Mar/2016 02:05:35 AM
I cleaned them thoroughly, but instead of getting the file name from before, I'm getting names such as "Superdmermod.A" from Super Mario Advance 4: Super Mario Bros. 3 and "Pokemondsept" from Pokemon Sapphire. When I try to run them in an emulator, nothing happens. I'll continue to clean them but the Game Boy plugin seems much more sensetive than the SNES or Genesis slots on the Retrode or my N64 Plugin. EDIT: Now I'm getting "Pokemonsept.A" from Pokemon Sapphire. Does the ".A" mean anything?
Title: Re: Game Boy plugin not working at all
Post by: RazorX2014 on 19/Mar/2016 03:55:59 AM
I cleaned them thoroughly, but instead of getting the file name from before, I'm getting names such as "Superdmermod.A" from Super Mario Advance 4: Super Mario Bros. 3 and "Pokemondsept" from Pokemon Sapphire. When I try to run them in an emulator, nothing happens. I'll continue to clean them but the Game Boy plugin seems much more sensetive than the SNES or Genesis slots on the Retrode or my N64 Plugin. EDIT: Now I'm getting "Pokemonsept.A" from Pokemon Sapphire. Does the ".A" mean anything?

i remember one of my games for the megadrive wouldnt dump correctly, it turned out it wasnt dumping it as the correct file size so i would recommend downloading the rom to get the correct file size unless you know and comparing with the one you get from the retrode.

also are the games your trying to dump legit, fakes, clones or homebrew ones?
Title: Re: Game Boy plugin not working at all
Post by: MarioRPGGeno on 19/Mar/2016 01:41:25 PM
All of my games are legit, but I'd rather not download a ROM to find the filesize.
Title: Re: Game Boy plugin not working at all
Post by: Aleron Ives on 19/Mar/2016 08:12:15 PM
You don't need to download anything to find the right file size. Use the DAT-o-MATIC database, instead:

http://datomatic.no-intro.org/

Most cart games are listed here.
Title: Re: Game Boy plugin not working at all
Post by: Wannado on 20/Mar/2016 03:02:32 PM
The garbled names you posted indicate that some pins still do not connect properly. Please check the following pins on the edge connectors and slots of the cartridge, plug-in and Retrode:
AD10 = GBA pin 16 / MD pin A27
AD06 = GBA pin 12 / MD pin A22
AD02 = GBA pin 08 / MD pin A26

Please also look for short-circuits on those pins inside the plug-in.

I think AD10 is to blame for getting "...mermo" instead of "...mario" and "...sept" instead of "...sapp", but it might also be AD02. If it were AD02 though, we should only get 8 bytes of the name, and then garbage.

"d" instead of a space (I guess) points at AD06.


Does anybody know a good cleaning method for the slots? Cotton swabs don't fit in there. (I recently used a flat screwdriver to scrape off some oxides, but that's a rather bad method, I guess.)
Title: Re: Game Boy plugin not working at all
Post by: ericbazinga on 20/Mar/2016 03:55:23 PM
The garbled names you posted indicate that some pins still do not connect properly. Please check the following pins on the edge connectors and slots of the cartridge, plug-in and Retrode:
AD10 = GBA pin 16 / MD pin A27
AD06 = GBA pin 12 / MD pin A22
AD02 = GBA pin 08 / MD pin A26

Please also look for short-circuits on those pins inside the plug-in.

I think AD10 is to blame for getting "...mermo" instead of "...mario" and "...sept" instead of "...sapp", but it might also be AD02. If it were AD02 though, we should only get 8 bytes of the name, and then garbage.

"d" instead of a space (I guess) points at AD06.


Does anybody know a good cleaning method for the slots? Cotton swabs don't fit in there. (I recently used a flat screwdriver to scrape off some oxides, but that's a rather bad method, I guess.)
Perhaps some game system cleaners?
Title: Re: Game Boy plugin not working at all
Post by: Aleron Ives on 20/Mar/2016 08:22:58 PM
I've had one person suggest dipping a paper towel in rubbing alcohol and then inserting it into the slot to clean the contacts. If you fold it enough times to make it fill the width of the slot, you may get enough friction to clean the pins.
Title: Re: Game Boy plugin not working at all
Post by: Pickle on 24/Mar/2016 01:20:33 PM
I find q-tips work quite well
Title: Re: Game Boy plugin not working at all
Post by: Aleron Ives on 24/Mar/2016 08:52:12 PM
How do you make them fit into the slot? The question was how to clean the contacts on your console/Retrode, not how to clean the contacts on the cartridge.
Title: Re: Game Boy plugin not working at all
Post by: Matthias_H on 31/Mar/2016 12:53:12 PM
I always had major trouble cleaning GB Carts. Some only worked after opening the shell and some serious rubbing alcohol action on the bare PCB. Garbled names means you're almost there.
Title: Re: Game Boy plugin not working at all
Post by: Retrode64 on 29/Apr/2016 04:15:59 PM
I have a guide for cleaning cartridges around here somewhere.
As far as cleaning the Retrode it's self a small piece of cardboard injected into the slot should suffice.
Although a better practice would be to always clean your games before they are used with Retrode or plugins.