Retrode Community Forum

General Category => General Discussion => Topic started by: Muzer on 20/May/2012 05:07:38 PM

Title: Atari 2600 adaptor doesn't like Atari games :/
Post by: Muzer on 20/May/2012 05:07:38 PM
I've just got around to testing my Atari 2600 adaptor. I tried my first game - Adventure - and no matter how many times I wiped the contacts, the data coming out was different to the real Adventure ROM I found, and the game wouldn't run. I then moved onto my next game, air-sea battle - same issue. I then took a look at the compatibility list - I found the games I had on that list were Frogger, Pitfall and missile command. Frogger and Pitfall worked first time without a hitch. I then moved onto missile command - I was getting the same issue as with Adventure and air-sea battle :/. These are all simple, 4k games with no mappers, and as I previously stated, missile command is in the very-old compatibility list.

I also noticed that the cartridge didn't look like it was sitting very happily, so I took the lid off the Retrode 2 (I assume it was better-suited to the original physically) - the same issue.

I have the latest firmware version.

I would hazard a guess at this early stage that it's something to do with the way the Atari circuit boards are made that this particular adaptor doesn't like for whatever reason - perhaps the connector is dodgy or something.

I'll give some more software a try that I know doesn't use any mappers, etc., and I'll try to do even more cleaning (but missile command is looking brand new!)

Attached is my many attempts at getting Missle Command to dump.
Title: Re: Atari 2600 adaptor doesn't like Atari games :/
Post by: Matthias_H on 21/May/2012 07:18:47 PM
And that's why I don't sell 2600er adapters any more :-) "Compatibility" according to this list means, I luckily got it to run after many attempts. I observed the same thing as you: even when the pins are already visually immaculate, more rubbing alcohol still seems to help.
Title: Re: Atari 2600 adaptor doesn't like Atari games :/
Post by: Muzer on 22/May/2012 04:05:54 PM
Ah, fair enough then, I'll break out my methylated spirits ;)

But I wonder where the issue really lies - just wondering if there's any possibility it could be a software thing at all (perhaps trying to read it too fast or something)? Just thinking aloud here, ignore me if I'm being an idiot ;)