Author Topic: SRAM not working with SNES games  (Read 2560 times)

Offline spacorn

  • Baby Retrode
  • *
  • Posts: 1
  • Karma: +0/-0
SRAM not working with SNES games
« on: 07/Jan/2016 08:20:07 PM »
Hey, I bought the Retrode 2 for the sole purpose of backing up my saved games. I've tried with two games now (Secret of Mana and Legend of Zelda Link to the Past). The saved files show up fine on the actual SNES hardware, but in both cases, the SRM file the Retrode 2 provides turns out blank. I've tried them in several emulators (RetroArch with different cores. Standalone Snes9x...). In every case, the saved files show up empty. I tried my carts again on the SNES afterwards, and they are still there, so it's not a corruption problem on the cart side.

What can I do to try to make it work?
Would a firmware update help?

The SFC files work ok, btw. It's just the SRAMs.

And yes, the emulators have their save files directories correctly configurated.
« Last Edit: 07/Jan/2016 08:24:11 PM by spacorn »

Offline Matthias_H

  • Retrode Forum Techie
  • A Retrode Hero
  • *****
  • Posts: 558
  • Karma: +21/-0
Re: SRAM not working with SNES games
« Reply #1 on: 07/Jan/2016 11:00:29 PM »
First step: e-mail me the SRM files so I can have a closer look. support at [productname] dot org

I no longer sell the Retrode. For sales inquiries, please contact our friends at DragonBox.

Offline bluegrassjedi

  • Baby Retrode
  • *
  • Posts: 15
  • Karma: +1/-0
Re: SRAM not working with SNES games
« Reply #2 on: 12/Oct/2017 03:17:35 AM »
October 2017 Update:
My The Legend of Zelda LTTP SNES cart is working just fine.
I am using a Retrode2 with .22 Beta FW. I have set on 5v.

I first thought it wasn't working until I tested the LOZ LTTP SNES cart on actual hardware.
When I downloaded the RAM file, it was empty. It had a bunch of 0's in the hex viewer.
I put the cart into actual hardware and THERE WERE ACTUALLY NO SAVES.
I registered a new name on the game and reset the console. It kept the save. Battery is ok.

I apologize for necro-posting.
I thought I had an issue at first, but not really.
I can't remember if I ever had saves on this SNES cart.